Starduino Port WIP

Use this forum to share and discuss Uzebox games and demos.
Post Reply
rv6502
Posts: 61
Joined: Mon Feb 11, 2019 4:27 am

Starduino Port WIP

Post by rv6502 » Sat Jun 26, 2021 4:55 am

Got it into the good-enough zone for the emulator to accept the picture.



But I broke the sound a while back... about a year ago.
And I don't remember what I did exactly... (I do have the git history but it was a huge refactor so it doesn't narrow it down much.)

Aaaaaanyway, getting close. :D
I think it's the last thing left to fix other than maybe tweaking the video timing a little bit more.

The emulator is still looking at me with a frown over that video timing :P
Screenshot_2021-06-26_00-52-38.jpeg
Screenshot_2021-06-26_00-52-38.jpeg (116.14 KiB) Viewed 1828 times

CunningFellow
Posts: 1256
Joined: Mon Feb 11, 2013 8:08 am
Location: Brisbane, Australia

Re: Starduino Port WIP

Post by CunningFellow » Sat Jun 26, 2021 8:43 am

noice

rv6502
Posts: 61
Joined: Mon Feb 11, 2019 4:27 am

Re: Starduino Port WIP

Post by rv6502 » Tue Jun 29, 2021 4:26 pm

rv6502 wrote:
Sat Jun 26, 2021 4:55 am
But I broke the sound a while back... about a year ago.
And I don't remember what I did exactly... (I do have the git history but it was a huge refactor so it doesn't narrow it down much.)
Okay, that was a silly bunch of hours spent looking for the problem

Code: Select all

#if ARDUBOY_ENABLE_MUSIC || ARDUBOY_ENABLE_SOUND
#include "audio_data.h"
#else
void *instrument_table[] = {};
#endif
I just needed to define ARDUBOY_ENABLE_SOUND :roll:

Now I gotta find out what part of the sound code makes the video signal glitch. Already ruled out interrupts being disabled.
Got a long Canada-day weekend coming up, should leave me some time to investigate the issue.

I think that's the last little bit left to fix.

I keep thinking, "Hey I should add some SD card FMV, that'd be neat" then I remember:
Screenshot_2021-06-29_11-46-36.jpg
Screenshot_2021-06-29_11-46-36.jpg (15.45 KiB) Viewed 1794 times
NOOOOOOPE!

That green dot is the stack-vs-heap smash sentinel. :lol:

Hitting the point of trying to get blood out of a stone :P
Gonna finish this port and move on to a clean new project.
Something more adapted to the Uzebox strengths.

rv6502
Posts: 61
Joined: Mon Feb 11, 2019 4:27 am

Re: Starduino Port WIP

Post by rv6502 » Thu Jul 01, 2021 9:41 pm

Man, do I feel silly :mrgreen:

I was starting to go nuts trying to figure out why the nested interrupts were seemingly not working while the audio code was enabled.
pic_4_1.jpg
pic_4_1.jpg (125.81 KiB) Viewed 1773 times
I forgot there was another audio mixer call in the vblank handler and I missed removing it during the refactoring a year back and that part didn't have nested interrupts enabled.
And it wasn't even supposed to be called from there anymore.
Screenshot_2021-07-01_17-05-21.jpg
Screenshot_2021-07-01_17-05-21.jpg (11.21 KiB) Viewed 1773 times
Finally time to package a release.
Wheeeeeeeeee!

User avatar
D3thAdd3r
Posts: 2474
Joined: Wed Apr 29, 2009 10:00 am
Location: Minneapolis, United States

Re: Starduino Port WIP

Post by D3thAdd3r » Fri Jul 02, 2021 1:07 am

I'm excited to see this :ugeek:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest