Emulator - get latest release here.

The Uzebox now have a fully functional emulator! Download and discuss it here.
User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Emulator - get latest release here.

Post by uze6666 » Sat Apr 17, 2010 3:52 am

Any chance of an updated pre-built for us lazy types?
Man, you guys are spoiled I'm telling you... ;) Built the trunk, it's available (Windows binaries) at gcode. If anyone can build Linux and Mac version, I'd appreciate.

-Uze

User avatar
nebososo
Posts: 188
Joined: Sun Oct 04, 2009 10:33 pm
Location: Curitiba, Paraná, Brazil
Contact:

Re: Emulator - get latest release here.

Post by nebososo » Sat Apr 17, 2010 4:27 am

uze6666 wrote:
Any chance of an updated pre-built for us lazy types?
Man, you guys are spoiled I'm telling you... ;) Built the trunk, it's available (Windows binaries) at gcode. If anyone can build Linux and Mac version, I'd appreciate.

-Uze
You are too.
Here's a Linux 32 bit binary.
And a Linux 64 bit binary.

They were compiled on a Pentium 4 and a Core I5, respectively. Using all the default option except for -O2 instead of -O3.

User avatar
paul
Posts: 457
Joined: Sat May 02, 2009 8:41 am
Location: Brisbane, Australia

Re: Emulator - get latest release here.

Post by paul » Sat Apr 17, 2010 4:41 am

Some people may have trouble building on Windows due to Makefile changes I made. On my XP computer I have SDL headers and libs bunched in with MinGW. The Makefile looks for them in C:/SDL/ and then C:/MinGW/. I commented out the -LC:\MinGW\lib to avoid a ton of errors involving libstdc++.a. So that could cause problems for others. You can uncomment it and remove my replacement line if that helps. I don't know why adding that library path to the LDFLAGS is a problem - maybe my MinGW install is messed up. Anyway, the safest option is to move your SDL install to C:/SDL and you shouldn't experience either of these problems. Hopefully someone smart can fix it up for everyone.

User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Emulator - get latest release here.

Post by uze6666 » Sat Apr 17, 2010 5:09 pm

You are too.
Here's a Linux 32 bit binary.
And a Linux 64 bit binary.

They were compiled on a Pentium 4 and a Core I5, respectively. Using all the default option except for -O2 instead of -O3.
All right, thanks! :D I 'll upload to the download section.

-Uze

Adrastos
Posts: 44
Joined: Wed Mar 03, 2010 5:40 am
Location: Edmonton, Canada

Re: Emulator - get latest release here.

Post by Adrastos » Wed Jun 16, 2010 12:28 am

Just want to report a bug in the latest release of the emulator (not sure where to put it..)

When using 2 player mode in the emulator, the start and select key bindings are not appropriate..
In the current code (avr8.cpp lines 1633-1644), z->select p1, x->start p1; n->select p2, m->select p2.

The help says the z is start, x is select for p1 and that n is start for p2 and m is select for p2. There currently isn't a binding for player 2 start button!

Simple enough to fix, change this:

Code: Select all

keymap snes_two_players[] =
{
	// P1
	{ SDLK_a, 0, PAD_LEFT }, { SDLK_s, 0, PAD_DOWN }, { SDLK_d, 0, PAD_RIGHT }, { SDLK_w, 0, PAD_UP },
	{ SDLK_q, 0, SNES_LSH }, { SDLK_e, 0, SNES_RSH }, { SDLK_r, 0, SNES_Y }, { SDLK_t, 0, SNES_X },
	{ SDLK_f, 0, SNES_B }, { SDLK_g, 0, SNES_A }, { SDLK_z, 0, PAD_SELECT }, { SDLK_x, 0, PAD_START },
	// P2
	{ SDLK_j, 1, PAD_LEFT }, { SDLK_k, 1, PAD_DOWN }, { SDLK_l, 1, PAD_RIGHT }, { SDLK_i, 1, PAD_UP },
	{ SDLK_u, 1, SNES_LSH }, { SDLK_o, 1, SNES_RSH }, { SDLK_p, 1, SNES_Y }, { SDLK_LEFTBRACKET, 1, SNES_X },
	{ SDLK_SEMICOLON, 1, SNES_B }, { SDLK_QUOTE, 1, SNES_A }, { SDLK_n, 1, PAD_SELECT }, { SDLK_m, 1, PAD_SELECT },
	END_OF_MAP
};
To this:

Code: Select all

keymap snes_two_players[] =
{
	// P1
	{ SDLK_a, 0, PAD_LEFT }, { SDLK_s, 0, PAD_DOWN }, { SDLK_d, 0, PAD_RIGHT }, { SDLK_w, 0, PAD_UP },
	{ SDLK_q, 0, SNES_LSH }, { SDLK_e, 0, SNES_RSH }, { SDLK_r, 0, SNES_Y }, { SDLK_t, 0, SNES_X },
	{ SDLK_f, 0, SNES_B }, { SDLK_g, 0, SNES_A }, { SDLK_z, 0, PAD_START }, { SDLK_x, 0, PAD_SELECT },
	// P2
	{ SDLK_j, 1, PAD_LEFT }, { SDLK_k, 1, PAD_DOWN }, { SDLK_l, 1, PAD_RIGHT }, { SDLK_i, 1, PAD_UP },
	{ SDLK_u, 1, SNES_LSH }, { SDLK_o, 1, SNES_RSH }, { SDLK_p, 1, SNES_Y }, { SDLK_LEFTBRACKET, 1, SNES_X },
	{ SDLK_SEMICOLON, 1, SNES_B }, { SDLK_QUOTE, 1, SNES_A }, { SDLK_n, 1, PAD_START }, { SDLK_m, 1, PAD_SELECT },
	END_OF_MAP
};

User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Emulator - get latest release here.

Post by uze6666 » Wed Jun 16, 2010 1:13 am

Nice find, thanks for the report. It's fixed, tested and committed!

-Uze

User avatar
nebososo
Posts: 188
Joined: Sun Oct 04, 2009 10:33 pm
Location: Curitiba, Paraná, Brazil
Contact:

Re: Emulator - get latest release here.

Post by nebososo » Sat Jul 02, 2011 2:33 am

Revision 186 now has proper uze file support on 64 bit (both uzem and packrom). So if you're running 64-bit, you might want to check it out from SVN or download a linux binary from here.

User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Emulator - get latest release here.

Post by uze6666 » Tue Jul 23, 2013 3:28 am

Version 1.16 was commited. It add emulation of timer functions required by newer video modes. Win32 pre-compiled executable can is available in the download section of SVN.

hpglow
Posts: 269
Joined: Wed Apr 14, 2010 6:06 am

Re: Emulator - get latest release here.

Post by hpglow » Thu Dec 05, 2013 5:54 am

I'm having Uzem hang when I launch it now. Even older versions hang. Did something change that I'm unaware of? I can't tell if it is hanging or just running so slow that my system things it is crashed. I'm running win7 64-bit. I've tried running as administrator and turning on XP compatibility modes. It used to work just fine a month agao, I wonder if some windows update broke it?

Is anyone else having these problems?

User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Emulator - get latest release here.

Post by uze6666 » Thu Dec 05, 2013 6:16 am

I heard issues with Win 7 x64 a couple times, but if you said it worked that is weird. Can you try building it from an earlier tag?

Post Reply

Who is online

Users browsing this forum: nicksen782 and 1 guest