Eclipse is not creating elf file

What is a Uzebox? How can I get one? Check here!
Post Reply
yllawwally
Posts: 73
Joined: Tue Mar 05, 2013 7:29 pm

Eclipse is not creating elf file

Post by yllawwally » Tue Mar 05, 2013 7:37 pm

I installed eclipse. When I try to debug the tutorial file, it says launching run_in_emulator. It does not show any errors, however I cannot find a new elf file on my computer. I followed the setup tutorial at http://uzebox.org/wiki/index.php?title= ... er_Eclipse Any advice on where I might have messed up the installation would be appreciated.

User avatar
uze6666
Site Admin
Posts: 4366
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Eclipse is not creating elf file

Post by uze6666 » Wed Mar 06, 2013 4:22 am

Does it build something? Do you see something in the condole? Normally the build log should end with something like this:

Code: Select all

AVR Memory Usage
----------------
Device: atmega644

Program:   46236 bytes (70.6% Full)
(.text + .data + .bootloader)

Data:       3912 bytes (95.5% Full)
(.data + .bss + .noinit)
Then your elf and hex will be in the /default folder.

yllawwally
Posts: 73
Joined: Tue Mar 05, 2013 7:29 pm

Re: Eclipse is not creating elf file

Post by yllawwally » Thu Mar 07, 2013 12:02 am

Thanks. I was looking at the console. Which erased the information too quickly. It can't find the make file.

yllawwally
Posts: 73
Joined: Tue Mar 05, 2013 7:29 pm

Re: Eclipse is not creating elf file

Post by yllawwally » Fri Mar 08, 2013 8:44 pm

I'm still trying to compile the tutorial. Make runs, however it cannot find a number of files such as fat.c, below is the output.

16:00:33 **** Incremental Build of configuration Debug for project testproject ****
make all
Building file: ../fat.c
Invoking: AVR Compiler
avr-gcc -Wall -g2 -gstabs -O0 -fpack-struct -fshort-enums -std=gnu99 -funsigned-char -funsigned-bitfields -mmcu=atmega644 -DF_CPU=28636360UL -MMD -MP -MF"fat.d" -MT"fat.d" -c -o "fat.o" "../fat.c"
../fat.c:25:20: warning: uzebox.h: No such file or directory
../fat.c:26:17: warning: mmc.h: No such file or directory
../fat.c:27:17: warning: fat.h: No such file or directory
../fat.c: In function 'InitFat':
../fat.c:39: warning: implicit declaration of function 'mmc_init'
../fat.c: In function 'LoadRootDirectory':
../fat.c:45: warning: implicit declaration of function 'mmc_readsector'
../fat.c:48: error: 'MBR' undeclared (first use in this function)
../fat.c:48: error: (Each undeclared identifier is reported only once
../fat.c:48: error: for each function it appears in.)
../fat.c:48: error: expected expression before ')' token
../fat.c:51: error: 'BootRecord' undeclared (first use in this function)
../fat.c:51: error: expected expression before ')' token
../fat.c:52: error: expected expression before ')' token
../fat.c:53: error: expected expression before ')' token
../fat.c:54: error: expected expression before ')' token
../fat.c:55: error: expected expression before ')' token
../fat.c: At top level:
../fat.c:63: error: expected ')' before '*' token
../fat.c:67: error: expected ')' before '*' token
make: *** [fat.o] Error 1

16:00:33 Build Finished (took 581ms)

yllawwally
Posts: 73
Joined: Tue Mar 05, 2013 7:29 pm

Re: Eclipse is not creating elf file

Post by yllawwally » Sat Mar 09, 2013 1:27 am

OK, got it to create an elf and a hex. But for some reason I had to rename my source file to tutorial? Would not create the elf when named testproject. I must have copied something I should have when copying the stuff from the tutorial.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests