Page 9 of 9

Re: Uzebox Quick Start

Posted: Mon Feb 23, 2015 6:15 am
by uze6666
Here's what is expected. In the picture below is the continuity tests to do and the resistance measurements expected. Unplug power and ideally remove the ATmega before. Then plug power and confirm you have 3.3v on pin 4.
pcbtest.jpg
pcbtest.jpg (197.85 KiB) Viewed 10409 times

Re: Uzebox Quick Start

Posted: Mon Feb 23, 2015 2:19 pm
by redcom001
There's no response between pin 6 on the atmega and pad 2 on the SD leads. All the others you noted give a reading. Is that my problem?

UPDATE: It was. I'll pop back in later after I test it out.

Re: Uzebox Quick Start

Posted: Thu Feb 26, 2015 9:30 pm
by redcom001
I got the socket in correctly, but the bootloader still says no SD card and there is a flashing red line now.

Re: Uzebox Quick Start

Posted: Fri Feb 27, 2015 1:22 am
by D3thAdd3r
Could you post a picture of it? This is really a strange problem, but I think it's still most likely a soldering problem. Did you try the UNO as an ISP to program .hex files directly? Does the game that came pre-programmed(megatris?) work correctly without any problems? If all connections are verified to be connected, the only possibilities are a bad '644(unlikely), a bad SD card(unlikely since you tested it), a bad SD socket(semi-likely if you desoldered and resoldered it) or you have the resistors in the wrong spot. Can't see what else it could be. A picture of the entire topside of the board could help to spot something.

Re: Uzebox Quick Start

Posted: Fri Feb 27, 2015 2:10 am
by uze6666
Usually, if the red bar shows its good sign, it means the card has initialized. If the list is empty, it can't read the sectors or FAT for some reason. A couple things:
-insure the ISP is not connected
-apply power without the sd card, then insert the sd card
-reformat the card in FAT16 and re-add some UZE files
-Test with another SD card

If you still can't make it work, I can always try to repair it if you are willing to sent it to me with return paid. Send me a PM if you're interested.

Re: Uzebox Quick Start

Posted: Fri Feb 27, 2015 2:50 am
by redcom001
I finally got it to work, I had to hold in the SD card with a goodly amount of force for the list to populate. Is there a contact that's not touching when it "clicks" in?

Re: Uzebox Quick Start

Posted: Fri Feb 27, 2015 2:55 am
by uze6666
Good!! I suspect there's a slight mismatch between the pins of the socket and the pads of the card. These cards are pretty cheap...

Re: Uzebox Quick Start

Posted: Thu Mar 19, 2015 1:29 am
by redcom001
New problem, it was working fine until today for no reason I can see. It will not work while an SD card is inserted, showing a blank screen, and gives the usual SD init fail when it isn't. I tried reformatting the card to no avail.

Re: Uzebox Quick Start

Posted: Fri Mar 20, 2015 2:17 am
by D3thAdd3r
As long as you have verified there is still electrical continuity to all the pins on the back of the SD socket, it seems apparent to me there is not much left beside a mechanical problem between the pins of the SD card and the pins of the socket. Did you ever try a different SD card that is 2gb or less? Clearly if you can format the card in question the pin alignment must be fairly close to standard for it to work with your PC.

IMHO, unfortunately, there is not much you can do besides get a new SD socket. I've never seen an SD card that had any apparent warping, but having to push very hard before to make it work says there is a contact issue. I was pretty new to soldering when I first started Uzebox, and like I said before I did over-cook an SD socket which wasn't apparent at first. My problem was I didn't understand how important it was to keep the tip clean and tinned with solder so the heat transfer works well...so I held it on too long and the plastic inside melted causing the pins to warp out of position. The soldering iron should probably touch each of those pins for 2 seconds max to complete the joint, and I wouldn't even risk doing them all in a row without a 20 second break in between(my failure made me a bit paranoid).