Help, AVRISP mkII driver support with Windows 7 64-bit

Share unrelated electronics stuff, ideas, rants, etc!
User avatar
DaveyPocket
Posts: 378
Joined: Sun Sep 14, 2008 8:33 pm
Contact:

Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DaveyPocket » Sat Jan 31, 2009 7:44 pm

So I finally got around to installing AVR studio on my Windows 7 partition. When I installed AVR studio, it said that the USB driver worked with Windows XP 32-bit and 64-bit, and Windows Vista 32-bit only. Now my guess is that Windows 7 applies to all the same stuff as Vista. Does anyone know of a third party driver that works with Vista 64-bit?

DavidEtherton
Posts: 252
Joined: Tue Dec 02, 2008 12:38 am
Location: Carlsbad, California (USA)

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton » Tue Feb 10, 2009 6:07 pm

You ever figure anything out on this? I downloaded both the 32bit and 64bit versions of Windows 7 and am on the fence as to which to install.

-Dave

User avatar
DaveyPocket
Posts: 378
Joined: Sun Sep 14, 2008 8:33 pm
Contact:

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DaveyPocket » Tue Feb 10, 2009 7:32 pm

It depends on what you're doing, 32-bit applications will work on a 64-bit platform, but drivers need to be specifically 64-bit for a 64-bit platform, which is the thing you need to worry about. Most printer drivers are designed for 32-bit, which angers me. But if you want to use all of your processing power and all of your RAM(more than 3 GB), then go with 64-bit. But it is all up to you, depending on what stuff you're running. I have not yet found a 64-bit driver for AVR ISP, but I will look harder.

DavidEtherton
Posts: 252
Joined: Tue Dec 02, 2008 12:38 am
Location: Carlsbad, California (USA)

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton » Tue Feb 10, 2009 10:24 pm

EDIT: Link to outdated thread removed. (AVR Studio 4.15 already claims to be fully Vista 64 compliant -- guess that's not the same as Win7 64!)
Last edited by DavidEtherton on Wed Feb 11, 2009 9:19 am, edited 1 time in total.

User avatar
DaveyPocket
Posts: 378
Joined: Sun Sep 14, 2008 8:33 pm
Contact:

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DaveyPocket » Wed Feb 11, 2009 12:50 am

My version I installed about a week ago, so it is currently not out of date. From the post it said there was going to be a driver soon. I don't know how soon.

DavidEtherton
Posts: 252
Joined: Tue Dec 02, 2008 12:38 am
Location: Carlsbad, California (USA)

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton » Wed Feb 11, 2009 1:19 am

EDIT: Link to outdated beta driver removed.
Last edited by DavidEtherton on Wed Feb 11, 2009 9:18 am, edited 1 time in total.

User avatar
DaveyPocket
Posts: 378
Joined: Sun Sep 14, 2008 8:33 pm
Contact:

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DaveyPocket » Wed Feb 11, 2009 2:04 am

Oh, I didn't see that, I quickly skimmed it because I was a bit busy with something. I will download it and try it out.

DavidEtherton64

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton64 » Wed Feb 11, 2009 8:28 am

I just installed win7 64bit, AVR Studio 4, and couldn't get the mkii to work with or without the new driver I posted. Hopefully you have better luck than I did. Now I need to see if my original partition is still around or if I just zorched my computer.

-Dave

DavidEtherton
Posts: 252
Joined: Tue Dec 02, 2008 12:38 am
Location: Carlsbad, California (USA)

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton » Wed Feb 11, 2009 8:35 am

DaveyPocket wrote:Oh, I didn't see that, I quickly skimmed it because I was a bit busy with something. I will download it and try it out.
I just installed Win7 64bit on a second partition and installed another copy of the Nov 08 AVR Studio 4 but I couldn't get it to recognize my mkII either with or without the new driver.

(Well, what I really did was install that usb driver first, noticed that it didn't properly recognize the device, then installed AVR Studio 4, and noticed it didn't make any difference. The control panel claims the .inf file is invalid)

Hopefully you'll have better luck.

-Dave

DavidEtherton
Posts: 252
Joined: Tue Dec 02, 2008 12:38 am
Location: Carlsbad, California (USA)

Re: Help, AVRISP mkII driver support with Windows 7 64-bit

Post by DavidEtherton » Wed Feb 11, 2009 9:17 am

Poking around some more, it seems like that beta usb driver is really old and has been superceded by newer releases of AVR Studio.

Unfortunately it seems that 4.15 claims to be fully Vista 64 compliant, but Win7 doesn't like it.
A service installation section in this INF is invalid.
I looked at the .inf file and didn't see anything obviously wrong, but I didn't exactly know what I was looking for either.

-Dave

ps. My machine has two hard drives in it (SCSI, don't ask). When I boot XP, they are C: and E: (and I can see my Win7 install on E:). When I boot Win7, it only sees a C: drive that is XP's E: drive. Anybody know how to get my original C: drive to show up?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest