My Uzebox...

Topics regarding the Uzebox hardware/AVCore/BaseBoard (i.e: PCB, resistors, connectors, part list, schematics, hardware issues, etc.) should go here.
User avatar
Kilo
Posts: 277
Joined: Wed Dec 19, 2012 3:43 pm
Location: AC, Germany

My Uzebox...

Post by Kilo » Thu Dec 20, 2012 10:06 am

Hi,

I'm 31 years old and from Germany...
After building 8-bit Basic Computer projects, I worked on the Uzebox and build it up!

I'm happy to get the whole PCB as small as I can so the Uzebox will fit in a enclosure of an external SAMSUNG burner. Looks great and looks like a tiny version of the PS3 :mrgreen: Pics will follow...

The connectors on the PCB are for SD Card, SNES Controller, SCART, LED'S, power button and reset button!
Still yet I've got some problems with the SD card, not knowing if it's cause of a wrong SD card or the wrong wiring of the card connector.. :(

Also problems with the crystal... I've tried many crystals (28,63636) but only a smd crystal was the right one... :?

greetings Dominik
Attachments
IMG1158a.jpg
IMG1158a.jpg (82.16 KiB) Viewed 3746 times
IMG1157a.jpg
IMG1157a.jpg (90.06 KiB) Viewed 3748 times
The last digit of Pi is 7! I calculated this, as I counted to infinity yesterday!

User avatar
Harty123
Posts: 467
Joined: Wed Jan 12, 2011 9:30 pm
Location: PM, Germany
Contact:

Re: My Uzebox...

Post by Harty123 » Thu Dec 20, 2012 1:32 pm

this looks really nice.

We (or you) should add your pictures to the homemade Uzeboxes in the wiki

http://uzebox.org/wiki/index.php?title= ... d_projects

Cheers

-Harty

User avatar
Kilo
Posts: 277
Joined: Wed Dec 19, 2012 3:43 pm
Location: AC, Germany

Re: My Uzebox...

Post by Kilo » Thu Dec 20, 2012 2:35 pm

Would be great... I can do this if you don't have the time :)
Or if you are in the mood... feel free to add :)

Dominik

PS: enclosure will follow... so, the next days there'll be new pics
The last digit of Pi is 7! I calculated this, as I counted to infinity yesterday!

User avatar
Janka
Posts: 213
Joined: Fri Sep 21, 2012 10:46 pm
Location: inside Out

Re: My Uzebox...

Post by Janka » Thu Dec 20, 2012 5:34 pm

Kilo wrote: Still yet I've got some problems with the SD card, not knowing if it's cause of a wrong SD card or the wrong wiring of the card connector.. :(
I had problems with an 2GB SD card, too. Seems like the SD/MMC card code in the loader is really a MMC only code. Older 256 MB or 16MB cards work.

TODO: Replace the SD/MMC code in the loader with the code from the SD2IEC project. That one can load from SDHC, too!

User avatar
Kilo
Posts: 277
Joined: Wed Dec 19, 2012 3:43 pm
Location: AC, Germany

Re: My Uzebox...

Post by Kilo » Thu Dec 20, 2012 6:23 pm

Thanks Janka,

could be a solution... but I have to check the wiring first. When I put in a SD card the whole Uzebox makes some noise and the tv is flickering... I guess it's the SD card connection!
strange... there are so many different cardholder with 7 pins, 9 pins, and so on!
The last digit of Pi is 7! I calculated this, as I counted to infinity yesterday!

User avatar
uze6666
Site Admin
Posts: 4487
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: My Uzebox...

Post by uze6666 » Thu Dec 20, 2012 7:31 pm

Looks great, thanks for sharing the pics! :D

SDHC code is on the todo list. Anyone's free to contribute... ;) The existing code is for SD and not MMC as far as I know (whats the difference btw), I used the SD consortium spec to write it...

User avatar
D3thAdd3r
Posts: 2422
Joined: Wed Apr 29, 2009 10:00 am
Location: Minneapolis, United States

Re: My Uzebox...

Post by D3thAdd3r » Thu Dec 20, 2012 10:32 pm

For some reason I thought we had a compatibility list for SD cards somewhere on the wiki, but I am not seeing it :?: Would be good to have if we don't

User avatar
Janka
Posts: 213
Joined: Fri Sep 21, 2012 10:46 pm
Location: inside Out

Re: My Uzebox...

Post by Janka » Fri Dec 21, 2012 12:03 am

uze6666 wrote:The existing code is for SD and not MMC as far as I know (whats the difference btw)
SD cards are only more picky in the init sequence, as far as I know.
I used the SD consortium spec to write it...
Reason why some newer SD cards won't work:

1. The spec isn't telling the whole truth (likely)
2. Card manufacturers can't read the spec (likely)
3. There is some minor bug in the code (likely)

4. All of the above (most likely) :P

User avatar
uze6666
Site Admin
Posts: 4487
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: My Uzebox...

Post by uze6666 » Fri Dec 21, 2012 2:52 am

3. There is some minor bug in the code (likely)
I'd even say *very* likely :lol:

User avatar
Kilo
Posts: 277
Joined: Wed Dec 19, 2012 3:43 pm
Location: AC, Germany

Re: My Uzebox...

Post by Kilo » Fri Dec 21, 2012 1:42 pm

Here are the new pics...

The front with the Uze Logo and some paintings will follow!

Greetings
Dominik
Attachments
uze2.jpg
uze2.jpg (19.65 KiB) Viewed 3622 times
IMG1164.jpg
IMG1164.jpg (42.36 KiB) Viewed 3618 times
The last digit of Pi is 7! I calculated this, as I counted to infinity yesterday!

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests