Five clock per pixel RLE mode

Topics related to the API, programming discussions & questions, coding tips, bugs, etc. should go here.
User avatar
uze6666
Site Admin
Posts: 4487
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Five clock per pixel RLE mode

Post by uze6666 » Thu Nov 07, 2019 1:00 am

Well - there has been progress since this thread. I posted a moving polygon HEX file here

http://uzebox.org/forums/viewtopic.php? ... 402#p30402

About a month after this threads last comment.
Yeah saw it, but I can't run it in CUzebox, just hangs. I guess there was a patch? Anybody has a recent windows build lying around? Or have the HEX so I can just run it on the hardware?

CunningFellow
Posts: 1192
Joined: Mon Feb 11, 2013 8:08 am
Location: Brisbane, Australia

Re: Five clock per pixel RLE mode

Post by CunningFellow » Thu Nov 07, 2019 2:17 am

Hopefully this works on your real hardware.

I'll look up and find the patch needed for Uzem to run in the emulator.
Attachments
SpinningShip.hex
(91.5 KiB) Downloaded 58 times

User avatar
uze6666
Site Admin
Posts: 4487
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: Five clock per pixel RLE mode

Post by uze6666 » Fri Nov 08, 2019 12:27 am

Hopefully this works on your real hardware.
It sure works fine...fast and smooth, it's very impressive!! :shock: Never though I would see big polygons like that on the Uzebox, kudos! But don't be such a tease, we need a game now! :P
I'll look up and find the patch needed for Uzem to run in the emulator.
Would be better for Cuzebox since I'm not using uzem anymore.

User avatar
Artcfox
Posts: 950
Joined: Thu Jun 04, 2015 5:35 pm
Contact:

Re: Five clock per pixel RLE mode

Post by Artcfox » Fri Nov 08, 2019 2:16 am


User avatar
Jubatian
Posts: 1407
Joined: Thu Oct 01, 2015 9:44 pm
Location: Hungary
Contact:

Re: Five clock per pixel RLE mode

Post by Jubatian » Fri Nov 08, 2019 8:25 pm

Artcfox wrote:
Fri Nov 08, 2019 2:16 am
This is the post with the patch: http://uzebox.org/forums/viewtopic.php? ... 170#p27772
Yes, that's it. For a moment I thought a branch or fork existed having it, but apparently not. Why it is not added to the mainline is that it is a very specific hack to get the RLE mode running, for the UART peripheral, whose exact clocking I never even considered. Given this use-case it might prove to be very difficult to get a properly functioning, and adequately performing actual UART emulation realized (which would be required for the ESP8266 which notably Lee was experimenting with, but L4rry also has a functional Tank-Fu for it already).

User avatar
Jubatian
Posts: 1407
Joined: Thu Oct 01, 2015 9:44 pm
Location: Hungary
Contact:

Re: Five clock per pixel RLE mode

Post by Jubatian » Wed Dec 18, 2019 11:21 pm

Jubatian wrote:
Fri Nov 08, 2019 8:25 pm
Yes, that's it. For a moment I thought a branch or fork existed having it, but apparently not.
Huh, I forgot that it doesn't exist since I merged the patch in! :) So if you happen to have a CUzeBox version which doesn't run the RLE demo, just do a fresh build from a fresh checkout. EDIT: I noticed that the binaries I am hosting are old, I updated those now! (those at the bottom of the first post in the emulator's thread, so grabbing the appropriate one from there should also run the RLE demo now).

CunningFellow
Posts: 1192
Joined: Mon Feb 11, 2013 8:08 am
Location: Brisbane, Australia

Re: Five clock per pixel RLE mode

Post by CunningFellow » Thu Dec 19, 2019 4:01 am

Thank you Jubatian,

I can confirm the Win32 binary works.

I better finish of that hexagon game now.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests