UCC2014 - Games are in!

Discuss Everything related to UCC, share progress of your game, ask questions, etc.
User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

UCC2014 - Games are in!

Post by uze6666 » Mon Nov 03, 2014 11:58 pm

Here's the games that crossed the finish line this year. Run from a freshly formatted SD card.

Games will be reviewed this week and results should be published November 8th.

Making a game is a big commitment in time and energy, so "Conglaturations" to all participants that made it! :mrgreen:

Uze
Attachments
UCC2014-games.zip
(1.06 MiB) Downloaded 248 times

User avatar
nicksen782
Posts: 667
Joined: Wed Feb 01, 2012 8:23 pm
Location: Detroit, United States
Contact:

Re: UCC2014 - Games are in!

Post by nicksen782 » Tue Nov 04, 2014 12:40 am

I just tried to run my game from your .zip file. It puts giberish on the screen like the tiles are all wrong or something.

So, I use a switch on Uzem. Here is a batch file that will help.

Code: Select all

@echo off
echo Current directory:
echo %cd%
echo.
uzem2 %1 -s %cd%\sd -v
The '-s' provides a location for the folder that will hold the files on the sd card for the game. (The sd folder is only required for the emulator.)
I did have some trouble starting 'CunningFellow-Tornado2000.hex'. How do you do it?

EDIT: 'DUH! Put the 'utempest.lvl' file in the sd card directory... OMG... Am I hearing VOICE in that game? WHOA!

User avatar
D3thAdd3r
Posts: 2422
Joined: Wed Apr 29, 2009 10:00 am
Location: Minneapolis, United States

Re: UCC2014 - Games are in!

Post by D3thAdd3r » Tue Nov 04, 2014 5:22 pm

Hey nicksen, I could have sworn I ran it normally before just by dragging and dropping. Now I went to run and it wouldn't work without the .bat setup so maybe I imagined it :? Obviously it's an emulator thing(I don't know if fragmentation on the real drive affects fragmentation on the emulated SD drive?). Just wanted to make sure, the screens should be looking like this?
nicksenzelda.png
nicksenzelda.png (34.27 KiB) Viewed 4398 times
Nice work everyone, I can see a lot of effort went into these and there are some nice games and promising WIP here. Good run guys!

hpglow
Posts: 269
Joined: Wed Apr 14, 2010 6:06 am

Re: UCC2014 - Games are in!

Post by hpglow » Tue Nov 04, 2014 5:46 pm

I haven't played them all yet, but some real nice entries. You guys are some good coders. I can't wait to look at some of the code for these games.

User avatar
nicksen782
Posts: 667
Joined: Wed Feb 01, 2012 8:23 pm
Location: Detroit, United States
Contact:

Re: UCC2014 - Games are in!

Post by nicksen782 » Tue Nov 04, 2014 7:18 pm

Yeah, those screenshots appear to be correct. My tile #0 was gray before and I changed it to include other colors. You need to use the -s option to specify the folder for the ow.bin file.

I found some 'weird' issues with the emulator. When it runs it just assumes that every file in the directory should be emulated so therefore I put my ow.bin file in it's own directory.

I was able to play my game on the emulator and the hardware as expected.

I could run Tornado 2000 on the emulator but not on the hardware. I really want to play that one on the hardware. It is really awesome. It's probably just something that I am doing wrong somehow. And YES fragmentation can mess things up easy. So just move the files off the sd card then move them back. That is a super simple defrag as far as I know.

CunningFellow
Posts: 1174
Joined: Mon Feb 11, 2013 8:08 am
Location: Brisbane, Australia

Re: UCC2014 - Games are in!

Post by CunningFellow » Wed Nov 05, 2014 12:56 am

Yes - good work people. Congrats. Especially you guys that got everything fully finished and polished.

JJHowards car game in particular is very complete. And he got it finished months before anyone else. Thumbs up.

Was very pleased to see Stache making a vector game there. I will have to back-port some of the improvements I made in Tempest back to the monochrome line drawing code.

User avatar
uze6666
Site Admin
Posts: 4449
Joined: Tue Aug 12, 2008 9:13 pm
Location: Montreal, Canada
Contact:

Re: UCC2014 - Games are in!

Post by uze6666 » Wed Nov 05, 2014 5:37 am

nicksen782 wrote:I just tried to run my game from your .zip file. It puts giberish on the screen like the tiles are all wrong or something.

So, I use a switch on Uzem. Here is a batch file that will help.
Hmmm, sure you can use a batch file but the latest uzem 0.19.1 should mount the directory that contains the runned HEX file as the SD card. What version do you use?
nicksen782 wrote:I could run Tornado 2000 on the emulator but not on the hardware. I really want to play that one on the hardware. It is really awesome. It's probably just something that I am doing wrong somehow. And YES fragmentation can mess things up easy. So just move the files off the sd card then move them back. That is a super simple defrag as far as I know.
What's the symptoms? One thing to be aware is that this game is sensitive to SD card timings. As far as I could see it's made to support both Regular SD and MicroSD card by "reputable" brands (Kingston, Sandisk, etc). Most cheap noname cards are often too slow and will screw up the background webs.

User avatar
Gosma
Posts: 66
Joined: Thu Oct 24, 2013 7:31 pm
Location: Santos, Brazil

Re: UCC2014 - Games are in!

Post by Gosma » Wed Nov 05, 2014 7:47 pm

Many cool games in this contest, can't even imagine the trouble to code. Hope i can participate next year.,

I want to play Tornado and Tempest 2000 in uzem but it gives SD card error, where i insert the SD files from that games?

User avatar
nicksen782
Posts: 667
Joined: Wed Feb 01, 2012 8:23 pm
Location: Detroit, United States
Contact:

Re: UCC2014 - Games are in!

Post by nicksen782 » Wed Nov 05, 2014 8:51 pm

I was using 1.17... I see that a new release is out. I'll use that now. Everything is good!
EDIT: No, I was using the latest version... I just forgot where I put it. I still replaced it with a fresh copy from the forums.

I do not know how to start Tornado 2000 on the uzebox hardware. I've used the bootloader and I've directly flashed the chip with the hex. The response is a blue screen on my tv like it is not getting any signal. My emulator usually doesn't run at full speed (I don't know why as I have a rather beefy computer.)

I'm using the 256 MB SD card that came with the Uzebox. I've even formatted the card and put only those two files on it. It seems like the bootloader failed at flashing the game.

User avatar
nicksen782
Posts: 667
Joined: Wed Feb 01, 2012 8:23 pm
Location: Detroit, United States
Contact:

Re: UCC2014 - Games are in!

Post by nicksen782 » Wed Nov 05, 2014 9:03 pm

Gosma wrote:I want to play Tornado and Tempest 2000 in uzem but it gives SD card error, where i insert the SD files from that games?
You will need to pass the sd card folder to the emulator. That's what I do. You will use the -s option. Something like %cd%\sdcard. I use a batch file that I associated with the emulator. It assumes all sd card files are in that folder. You could probably skip the '\sd' part if you want to just present any files in that directory to the emulator. I prefer a separate folder. It works pretty well on the emulator. Rather awesome.

Remember, unless the uzem.exe file is in the same directory as your .hex/.uze and sd card file you'll need to pass the directory to uzem.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest